# Node exporter service not getting start

**URL:** <https://discuss.prometheus.io/t/node-exporter-service-not-getting-start/1808>\
**Category:** node\_exporter\
**Created:** [August 11, 2023, 5:54am UTC](https://discuss.prometheus.io/t/node-exporter-service-not-getting-start/1808 "2023-08-11T05:54:29Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![Venkat](https://avatars.discourse-cdn.com/v4/letter/v/4491bb/32.png) [@Venkat](https://discuss.prometheus.io/u/Venkat)\
**Post date:** [August 11, 2023, 5:54am UTC](https://discuss.prometheus.io/t/node-exporter-service-not-getting-start/1808/1 "2023-08-11T05:54:29Z")

</div>

Hi All,

Any fix for below node expoter service issue.

● node\_exporter.service - node exporter for Prometheus  
Loaded: loaded (/etc/systemd/system/node\_exporter.service; enabled; vendor preset: disabled)  
Active: failed (Result: start-limit) since Fri 2023-08-11 07:28:26 CEST; 17min ago  
Process: 2303 ExecStart=/opt/node\_exporter/node\_exporter --web.config=tls\_config.yml --web.listen-address=:10020 --collector.processes --collector.systemd (code=exited, status=1/FAILURE)  
Main PID: 2303 (code=exited, status=1/FAILURE)

systemd[1]: Unit node\_exporter.service entered failed state.  
systemd[1]: node\_exporter.service failed.  
systemd[1]: node\_exporter.service holdoff time over, scheduling restart.  
systemd[1]: Stopped node exporter for Prometheus.  
systemd[1]: start request repeated too quickly for node\_exporter.service  
systemd[1]: Failed to start node exporter for Prometheus.  
systemd[1]: Unit node\_exporter.service entered failed state.  
systemd[1]: node\_exporter.service failed.

---

<div class="post-metadata">

**Author:** ![Venkat](https://avatars.discourse-cdn.com/v4/letter/v/4491bb/32.png) [@Venkat](https://discuss.prometheus.io/u/Venkat)\
**Post date:** [August 11, 2023, 5:55am UTC](https://discuss.prometheus.io/t/node-exporter-service-not-getting-start/1808/2 "2023-08-11T05:55:32Z")

</div>

Is there any one has found this issue , pls give the solution to fix

---

<div class="post-metadata">

**Author:** ![salessandri](https://dub1.discourse-cdn.com/flex017/user_avatar/discuss.prometheus.io/salessandri/32/814_2.png) [@salessandri](https://discuss.prometheus.io/u/salessandri)\
**Post date:** [September 27, 2023, 5:06am UTC](https://discuss.prometheus.io/t/node-exporter-service-not-getting-start/1808/3 "2023-09-27T05:06:27Z")

</div>

Have you tried running the command as `systemd` tries to and see whether its successful or not. And if not, what you get as the output. From what I can tell, `systemd` is trying to start it but the underlying process bails out with retcode 1.

You should first try to run `/opt/node_exporter/node_exporter --web.config=tls_config.yml --web.listen-address=:10020 --collector.processes --collector.systemd` from the `WorkingDirectory` and as the user that the systemd service is configured to run as (likely `root`?)
