# Unable to Install kube-prometheus-stack on Kubernetes Cluster

**URL:** <https://discuss.prometheus.io/t/unable-to-install-kube-prometheus-stack-on-kubernetes-cluster/3390>\
**Category:** General Help/Support\
**Created:** [May 12, 2025, 3:17pm UTC](https://discuss.prometheus.io/t/unable-to-install-kube-prometheus-stack-on-kubernetes-cluster/3390 "2025-05-12T15:17:47Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![dazeez](https://avatars.discourse-cdn.com/v4/letter/d/d07c76/32.png) [@dazeez](https://discuss.prometheus.io/u/dazeez)\
**Post date:** [May 12, 2025, 3:17pm UTC](https://discuss.prometheus.io/t/unable-to-install-kube-prometheus-stack-on-kubernetes-cluster/3390/1 "2025-05-12T15:17:47Z")

</div>

I am trying to install the kube-prometheus-stack on my Kubernetes cluster but unfortunately i get

`Error: INSTALLATION FAILED: YAML parse error on kube-prometheus-stack/templates/exporters/kube-etcd/servicemonitor.yaml: error converting YAML to JSON: yaml: line 19: mapping values are not allowed in this context`

Any Idea what i am doing wrong?

I’m tying to install the version 72.3.0  
My helm version is 3.18.0-rc.1

My Kubernetes details (Oracle Kubernetes Engine)  
Client Version: v1.29.0  
Kustomize Version: v5.0.4-0.20230601165947-6ce0bf390ce3  
Server Version: v1.28.3+3.el8

---

<div class="post-metadata">

**Author:** ![asdkn2344](https://avatars.discourse-cdn.com/v4/letter/a/8edcca/32.png) [@asdkn2344](https://discuss.prometheus.io/u/asdkn2344)\
**Post date:** [May 16, 2025, 7:49pm UTC](https://discuss.prometheus.io/t/unable-to-install-kube-prometheus-stack-on-kubernetes-cluster/3390/2 "2025-05-16T19:49:53Z")

</div>

I had the same issue. Turns out I was using a Helm release candidate version v3.18.0-rc.2 (and not the most recent stable version, v3.17.3).

Downgrading to 3.17.3 resolved the issue.
