Attempting install Node Mixin - error

I’m attempting to install Node Mixin, as described at
node_exporter/docs/node-mixin at master · prometheus/node_exporter · GitHub.

The three "go get . . . " commands executed without error, however jb install results in a “command not found”

Any suggestions on moving forward with this install?


Do you have jb in your path? Can you try go install instead of go get ?

Thanks @roidelapluie.

go install . . . worked on all three lines (no error anyway)

go env returned, among all the other env info:


Not sure which should be in my path, but neither one is.

Nevertheless, I cd’d to both, executed
“jb install” which again resulted in command not found.

You could try export PATH=$PATH:$GOPATH/bin before running the commands.

added /storage/home/hcodaman1/gbeyer3/go to path. Still getting command not found for jb install. Which is crazy, as it shows in a ls:

[gbeyer3@gbeyer-test /storage/home/hcodaman1/gbeyer3/go/bin]$ll
total 20202
-rwxr-xr-x 1 gbeyer3 pace-admins 10046085 Mar 19 09:50 jb
-rwxr-xr-x 1 gbeyer3 pace-admins 6075177 Mar 19 09:50 jsonnet
-rwxr-xr-x 1 gbeyer3 pace-admins 4296713 Mar 19 09:50 jsonnetfmt

OK, I figured out – the documentation is wrong at the first Grafana URL I referenced :frowning:

The command SHOULD be ./jb install At least I get something to happen with ./

BUT I still get a new error:

[gbeyer3@gbeyer-test /storage/home/hcodaman1/gbeyer3/go/bin]$./jb install
jb: error: failed to load jsonnetfile: open /storage/home/hcodaman1/gbeyer3/go/bin/jsonnetfile.json: no such file or directory

It seems I’m missing .json file(s) ?

You would need to go to where you cloned prometheus, then run /storage/home/hcodaman1/gbeyer3/go/bin/jb.

I think this is what you mean. Prometheus is installed (cloned?) in /gbeyer3/prometheus-2.24.1.linux-amd64

Within that dir I executed ./storage/home/hcodaman1/gbeyer3/go/bin/jb

ls -l shows that the jb file exists and is executable, still I get a no such file or directory.

[gbeyer3@gbeyer-test /storage/home/hcodaman1/gbeyer3/prometheus-2.24.1.linux-amd64]ls -l /storage/home/hcodaman1/gbeyer3/go/bin/jb -rwxr-xr-x 1 gbeyer3 pace-admins 10046085 Mar 19 09:50 /storage/home/hcodaman1/gbeyer3/go/bin/jb [gbeyer3@gbeyer-test /storage/home/hcodaman1/gbeyer3/prometheus-2.24.1.linux-amd64]./storage/home/hcodaman1/gbeyer3/go/bin/jb
-bash: ./storage/home/hcodaman1/gbeyer3/go/bin/jb: No such file or directory

Use /storage/home/hcodaman1/gbeyer3/go/bin/jb (without the dot).