Need to avoid mountpoint=/tmp/snap.rootfs_xxxxx

in my prometheus server / alert manager setup
hdd alerts for a single server 163 alerts are firing for the mount points /tmp/snap.rootfs_xxxxxx
attached screenshot

my alert rule is

  • alert: HostOutOfDiskSpace
    expr: (node_filesystem_avail_bytes * 100) / node_filesystem_size_bytes < 15 and ON (instance, device, mountpoint) node_filesystem_readonly == 0
    for: 5m
    severity: warning
    summary: Host out of disk space (instance {{ $labels.instance }})
    description: “Disk is almost full (< 15% left)\n VALUE = {{ $value }}\n LABELS = {{ $labels }}”

i tried delete mountpoint parameter in the above rule but of no use it triggers almost 163 alerts in single mail for all /tmp/snap.rootfs_xxxx
i need alert for mountpoint = / alone is enough but it triggers mountpoint = /tmp/snap.rootfs_xxxxxx
i want to avoid the alerts for mount points /tmp/snap.rootfs_xxxxx and need to achieve
single alert firing for HDD
any suggestions in alert rule to achieve this

expr: 100 - ((node_filesystem_avail_bytes{mountpoint="/",fstype!=“tmpfs”} * 100) / node_filesystem_size_bytes{mountpoint="/",fstype!=“tmpfs”}) > 85

by including fstype!=“tmpfs” in expr will fix the problem