Node Exporter Does not Start on macOS

I am trying to set up a node exporter on macOS.
The CPU type is M1.
I did a wget of from the repository and tried to run, but it tells me it got killed.

Are there any pointers or precautions to run Node Exporter on Apple Silicon?

I appreciate your help.

A sample run log is below.

hisaotsu-mac myexporter % wget
--2023-10-31 16:11:41--
Resolving  <proxy server name>... <IP address>
Connecting to <proxy server name>|<IP address>|:<port>... connected.
Proxy request sent, awaiting response... 302 Found
Location: [following]
--2023-10-31 16:11:41--
Connecting to <proxy address and IP>|:<port number>... connected.
Proxy request sent, awaiting response... 200 OK
Length: 4548399 (4.3M) [application/octet-stream]
Saving to: ‘node_exporter-1.6.1.darwin-arm64.tar.gz’
node_exporter-1.6.1.darwin-arm64. 100%[==========================================================>]   4.34M  3.35MB/s    in 1.3s
2023-10-31 16:11:43 (3.35 MB/s) - ‘node_exporter-1.6.1.darwin-arm64.tar.gz’ saved [4548399/4548399]
hisaotsu-mac myexporter %
hisaotsu-mac myexporter % ls
hisaotsu-mac myexporter % tar xvfz node_exporter-1.6.1.darwin-arm64.tar.gz
x node_exporter-1.6.1.darwin-arm64/
x node_exporter-1.6.1.darwin-arm64/NOTICE
x node_exporter-1.6.1.darwin-arm64/node_exporter
x node_exporter-1.6.1.darwin-arm64/LICENSE
hisaotsu myexporter % cd node_exporter-1.6.1.darwin-arm64
hisaotsu node_exporter-1.6.1.darwin-arm64 % ./node_exporter
zsh: killed     ./node_exporter

Building from the source solved the problem.